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About This Guide 
The Exclaimer Mail Archiver Outlook Add-In allows users to easily search, view and restore messages 

from your email archive using Microsoft Outlook.   

This guide details information that you will need to install and configure the Add-In, including system 

requirements and download instructions. 



 

 
 
 

DEPLOYMENT GUIDE - EXCLAIMER MAIL ARCHIVER 
OUTLOOK ADD-IN 

Exclaimer Mail Archiver 

P a g e  |  4  

System Requirements 
System requirements for hardware and software are summarized in the following sections. 

Software   
Item Minimum Requirements 

Operating Systems  Windows XP x86 SP3 

Windows Vista x86 and x64 (including all service pack levels) 

Windows 7 x86 and x64 (including all service pack levels) 

Windows 8 x86 and x64 

Windows 8.1 x86 and x64 

Windows 10 x86 and x64 

Microsoft .NET Framework Microsoft .Net Framework 3.5  

Microsoft Outlook Outlook 2007 SP3 with Visual Studio Tools for Office Run-Time 2010 

Outlook 2010 x86 and x64 (including all service pack levels) 

Outlook 2013 x86 and x64 

Outlook 2016 x86 and x64 

 
 

http://go.microsoft.com/fwlink/?LinkId=140384
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Installation Files 
The Exclaimer Mail Archiver Outlook Add-In has two installers: 

 MailArchiverOutlookAddIn64.msi (for 64-bit computers) 

 MailArchiverOutlookAddIn32.msi (for 32-bit computers) 

These files are included as part of the main Exclaimer Mail Archiver installation and can be found  

in the Exclaimer Mail Archiver folder (the default folder is c:\program files\exclaimer ltd\mail 

archiver). 

Copy these files to a network share that can be accessed by all required computers within your 

organization. 

N
O

TE 

If you are installing the software on a 64-bit operating system that has a 32-bit version of 
Microsoft Outlook, you should use the MailArchiverOutlookAddIn64.msi package. 
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Deployment Preparation 
To deploy the Exclaimer Mail Archiver Outlook Add-In you must have first installed and configured 

Exclaimer Mail Archiver.  

To use features such as viewing and restoring messages, you must have completed the following 

tasks within Exclaimer Mail Archiver (i.e. on the Exclaimer Mail Archiver server): 

 Run the Exchange Mailbox Access Account Wizard. Please refer to the Mail Archiver Settings 
section of the User Guide for Exclaimer Mail Archiver 

 Set the Enable Restore To Mailbox option to ‘enabled’ in Mail Archiver Settings. Please refer  
to the Mail Archiver Settings section of the User Guide for Exclaimer Mail Archiver 

Once these tasks have been completed, you can install the Add-In manually [pg.7], or by using  

a Group Policy [pg.8]. 
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Installing the Add-In Manually 
To install the Exclaimer Mail Archiver Outlook Add-In manually, perform the following steps on each 

required computer (you will require local administrator rights to complete the installation). 

1. Click Start and then Run. 

2. Type cmd and then click OK. 

3. Change into the directory where MSI files were copied (see the Installation Files section [pg.5]). 

4. For 64-bit systems, run the MSI package by entering the following command: 

msiexec /i MailArchiverOutlookAddIn64.msi MAWEBSITEURL=http://servername:port 

-or- 

For 32-bit systems: Run the MSI package by entering the following command: 

msiexec /i MailArchiverOutlookAddIn32.msi MAWEBSITEURL=http://servername:port 

- 

N
O

TE 

The parameter “MAWEBSITEURL” is case-sensitive.  Replace servername:port with the server name 
and port of the web-site used for Exclaimer Mail Archiver.  The default port used is 53444. 
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Installing the Add-In Using 
Group Policy 
In a typical Active Directory environment, deployment through Group Policy is the fastest way  

to install the Exclaimer Mail Archiver Outlook Add-In without needing to manually install the 

software on each computer within your organization. To do this, complete steps detailed in the 

following sections: 

 Generate an MST File for Your Environment [pg.9] 

 Build a WMI Filter for x86 Computers [pg.11] 

 Build a WMI Filter for x64 Computers [pg.13] 

 Create a Group Policy for x86 Computers [pg.15] 

 Create a Group Policy for x64 Computers [pg.18] 

Having completed these steps, the Group Policy is built and deployed to all computers within your 

organization. The Exclaimer Mail Archiver Outlook Add-In will be installed automatically when the 

Group Policy is applied (by default every 90 minutes) and the computer is next rebooted. However, 

if required you can force the update to take effect immediately [pg.20] on a computer. 

N
O

TE 

To perform these steps you will need access to the Group Policy Editor and 
Orca. Orca is freely available from Microsoft as part of the Windows SDK. 
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Generate an MST File for Your Environment 
In order to install the Add-in you must provide a parameter which specifies the Archiver webserver 
URL and its associated port number. When installing the MSI manually this is done as a parameter 
on the command line. When deploying via Group Policy this parameter can only be specified inside 
an associated MST file. 
 
The process below creates this MST file.  By using it with the MSI file, Group Policy will automatically 
and silently install and configure the Outlook Add-In ready for use on computers in your organization. 
  
1. Ensure that MailArchiverOutlookAddIn32.MSI and MailArchiverOutlookAddIn64.MSI files have 

been copied to a shared network location that is accessible by all computers within your 
organization. 

2. Click Start > All Programs > Orca. 

3. Click File > Open. 

4. Open MailArchiverOutlookAddIn32.MSI. 

5. Click Transform > New Transform. 

6. From the list of Tables on the left, click Property.  A list of properties is displayed in the left-hand 
pane: 
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7. Right-click under the list of properties and choose Add Row. The Add Row dialog is displayed - 
from here: 

a. Enter the Property as MAWEBSITEURL (this is case sensitive). 

b. Enter the Value as http://servername:port.  Replace servername:port with the server  

name and port of the web-site that is used for Exclaimer Mail Archiver.  The default  

port used is 53444: 

 

c. Click OK to close the Add Row dialog. 

d. Click Transform > Generate Transform…  to display the Save Transform As dialog.  Save the 

MST file to the same location as the MSI files that you copied in step 1 [pg.9]. 

e. Click File > Exit to close Orca. 

N
O

TE 

The same MST file is used for both 32 and 64 bit installers. 
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Build a WMI Filter for x86 Computers 
 
 
This section only applies if you are deploying the Add-In to a mixture of 32-bit and 64-bit computers 
and is required for the group policy to identify the correct version of the Add-In for each computer.  
 
The steps below are required to identify the 32-bit computers in your organization and ensures the 
correct 32-bit Add-In is installed on them.  
 
1. Click Start > Administrative Tools > Group Policy Management 

2. Expand the tree and select WMI Filters: 

 

3. In the Contents pane on the right-hand side, right-click and select New… to display the New WMI 
Filter dialog. From here: 

a. Enter the Name as x86 Computers. 

b. If required, enter a description for this filter. 

c. Click Add to display the WMI Query dialog. 

d. Ensure that the Namespace is root\CIMv2. 
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e. Enter the Query as: Select * from Win32_Processor where AddressWidth = '32'.  

This is shown below: 

 

f. Click OK to close the WMI Query dialog. 

g. Click Save to close the New WMI Filter dialog: 
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Build a WMI Filter for x64 Computers 
This section only applies if you are deploying the Add-In to a mixture of 32-bit and 64-bit computers 
and is required for the group policy to identify the correct version of the Add-In for each computer.  
 
The steps below are required to identify the 64-bit computers in your organization and ensures the 
correct 64-bit Add-In is installed on them.  
 
1. Access the WMI Filters branch of the Group Policy Management tree (click Start > Administrative 

Tools > Group Policy Management if you are not already working within this tree). 

2. In the Contents pane on the right-hand side, right-click and select New… to display the New WMI 
Filter dialog. From here: 

a. Enter the Name as x64 Computers. 

b. If required, enter a description for this filter. 

c. Click Add to display the WMI Query dialog. 

d. Ensure that the Namespace is root\CIMv2. 

e. Enter the Query as: Select * from Win32_Processor where AddressWidth = '64'.  

This is shown below: 

 

f. Click OK to close the WMI Query dialog. 
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g. Click Save to close the New WMI Filter dialog: 
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Create a Group Policy for x86 Computers 
These steps are required if you have 32-bit computers in your organization.  This step links the filter 
for 32-bit computers you created earlier with the 32-bit MSI file. 
 
1. From the left-hand side of the Group Policy Management tree, right-click your domain branch 

(click Start > Administrative Tools > Group Policy Management if you are not already working 
within this tree). 

2.  Select Create a GPO in this domain, and Link it here… as shown below: 

 

3. The New GPO dialog is displayed. From here: 

a. Enter the name as Mail Archiver Add-In x86. 

b. Click OK. 
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4. A new Group Policy Object named Mail Archiver Add-In x86 is now shown in the tree on the left-
hand side. Right-click this object and select Edit… as shown below: 

 

5. From here: 

a. The Group Policy Management Editor window is displayed. 

b. From the tree on the left-hand side, expand the Mail Archiver Add-in x86 branch and then 

drill down to Computer Configuration > Policies > Software Settings and select Software 

installation: 

 

c. In the pane on the right-hand side, right-click and select New > Package…to display the 

Open dialog. 

d. Navigate to the network share where you placed the MSI files (see the Installation Files 

section [pg.5]) and double-click MailArchiverOutlookAddIn32.msi. The Deploy Software 

dialog is displayed.   

e. Choose Advanced and click OK. After a few seconds the Exclaimer Mail Archiver Outlook 

Add-In Properties dialog is displayed. From here: 

i. Select the Modifications tab. 
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ii. Click Add. 

iii. Navigate to the directory where the MSI files are located and double-click the MST 

file you created in earlier (see page 9). 

iv. Click OK to close the Exclaimer Mail Archiver Outlook Add-In Properties dialog. 

f. Close the Group Policy Management Editor. 
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Create a Group Policy for x64 Computers 
These steps are required if you have 64-bit computers in your organization. This step links the filter 
for 64-bit computers you created earlier with the 64-bit MSI file. 
 
1. From the left-hand side of the Group Policy Management tree, right-click your domain branch 

(click Start > Administrative Tools > Group Policy Management if you are not already working 
within this tree). 

2.  Select Create a GPO in this domain, and Link it here… as shown below: 

 

3. The New GPO dialog is displayed. From here: 

a. Enter the name as Mail Archiver Add-In x64. 

b. Click OK. 
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4. A new Group Policy Object named Mail Archiver Add-In x64 is now shown in the tree on the left-
hand side. Right-click this object and select Edit… as shown below: 

 

5. From here: 

a. The Group Policy Management Editor window is displayed. 

b. From the tree on the left-hand side, expand the Mail Archiver Add-in x64 branch and then 

drill down to Computer Configuration > Policies > Software Settings and select Software 

installation: 

 

c. In the pane on the right-hand side, right-click and select New > Package…to display the 

Open dialog. 

d. Navigate to the network share where you placed the MSI files (see the Installation Files 

section [pg.5]) and double-click MailArchiverOutlookAddIn64.msi. The Deploy Software 

dialog is displayed.   
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e. Choose Advanced and click OK. After a few seconds the Exclaimer Mail Archiver Outlook 

Add-In Properties dialog is displayed. From here: 

i. Select the Modifications tab. 

ii. Click Add. 

iii. Navigate to the directory where the MSI files are located and double-click the 

MST file you created in earlier (see page 9). 

iv. Click OK to close the Exclaimer Mail Archiver Outlook Add-In Properties dialog. 

f. Close the Group Policy Management Editor. 

Applying the Group Policy 
The Group Policy is now built and deployed to all computers within your organization. The software 

will be installed automatically when the Group Policy is applied (by default every 90 minutes) and 

the computer is next rebooted.   

If you wish to force the update to take effect immediately on a particular computer, follow the steps 

below: 

1. Click Start and then Run. 

2. Enter gpupdate /force and then click OK. 

3. You will be prompted to restart the computer.  Enter Y (Yes) and the computer restarts.  The 
Exclaimer Mail Archiver Outlook Add-In is installed when the computer restarts. 
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Additional Information 

Allowing Users to Change the Mail Archiver Add-
in Username 
When a user logs in to the Mail Archiver add-in using Outlook, their username is set to the primary 

email address of the default mail account in their Outlook profile. By default, they are unable to 

change the username. 

However, if users have multiple email accounts, or need to use a different username, you can add a 

registry setting to allow the users to change the username manually. To achieve this, follow the steps 

below on each client computer. 

N
O

TE 

These instructions involve making a change to the Windows Registry.  We strongly advise 
that you complete a backup of the Windows Registry before following these steps. 

1. Click Start and then Run. 

2. Enter regedit and click OK to open the Registry Editor. 

3. Expand the tree in the left-hand pane and navigate to the appropriate path below: 

For 64-bit Windows with 32-bit Outlook: 

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Exclaimer Ltd\Mail Archiver 

1.0\OutlookAddIn 

For example: 
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For 32-bit Windows, or 64-bit Outlook: 

HKEY_LOCAL_MACHINE\Software\Exclaimer Ltd\Mail Archiver 1.0\OutlookAddIn 

For example: 

 

N
O

TE 

If the required path does not exist, you should create it. 

4. In the right-hand pane, right-click and select New > DWORD (32-bit) Value: 

 

5. Enter the name as EnableUsernameEditing. 

6. Double-click the property to change its value and set the value to 1: 

 

7. Click OK to close the Edit DWORD (32-bit) Value dialog. 
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8. Click File and then Exit to close the Registry Editor. 

9. Restart Microsoft Outlook. 

10. Go to the Mail Archiver add-in in Outlook, and click Sign Out. 

11. Click Search and the login prompt is displayed. The user can now enter a different username: 
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Allowing Users to Change the Mail Archiver URL 
By default, when a user selects the Settings button from the Exclaimer Mail Archiver Outlook Add-

In, they are unable to enter a custom URL - it is fixed to the URL used when the Add-In was installed.  

However, if you have multiple Mail Archiver servers, you may wish to allow users to change the URL 

manually.  To achieve this, follow the steps below on each client computer (these steps apply to the 

logged on user only). 

N
O

TE 

These instructions involve making a change to the Windows Registry.  We strongly advise 
that you complete a backup of the Windows Registry before to following these steps. 

1. Click Start and then Run. 

2. Enter regedit and click OK to open the Registry Editor. 

3. Expand the tree in the left-hand pane to the path: 

HKEY_CURRENT_USER\Software\Exclaimer Ltd\Mail Archiver 1.0\OutlookAddIn 

4. In the right-hand pane, right-click and select New > DWORD (32-bit) Value: 

 

5. Enter the name as EnableChangeURL. 

6. Double-click the property to change its value and set the value to 1: 

 

7. Click OK to close the Edit DWORD (32-bit) Value dialog. 

8. Click File and then Exit to close the Registry Editor. 

9. Restart Microsoft Outlook. 
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10. Click the Settings button from the Mail Archiver area. The user can now change the URL: 
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Upgrading 
Upgrading can be achieved by deploying a newer version of the MSI.   

You do not need to uninstall the current version of the Exclaimer Mail Archiver Outlook Add-In to 

install a newer version - the newer version will automatically uninstall the older version during the 

installation process. 

If the Mail Archiver Name Changes 
If the name of your Mail Archiver server changes (for example, if you replace the physical server) 

then you simply need to re-deploy the same MSI with the new address.  This will update the address 

on the client computers in your organization. 
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Copyright Notice  
The information in this document is subject to change without notice. Exclaimer Ltd assumes no 

responsibility for any errors that may appear in this document. Unless otherwise noted, the example 

companies, organizations, products, domain names, e-mail addresses, logos, people, places and 

events depicted herein are fictitious and not associated with any real company, organization, 

product, domain name, e-mail address, logo, person, place or event.  

Exclaimer Mail Archiver and other Exclaimer devices are either registered trademarks or trademarks 

of Exclaimer Ltd in the United Kingdom and/or other countries. Exclaimer may have trademarks, 

copyrights or other intellectual property rights covering subject matter in this document. All other 

company and product names are acknowledged as being the trademarks or registered trademarks 

of their respective companies.  

Unless expressly provided in a written license agreement from Exclaimer Ltd, the furnishing of this 

document does not give you any license to these trademarks, copyrights or other intellectual 

property.  
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